MAC Snow Leopard NOT compatible with Parallels 2.5/3.0

Like if this guide is helpful
Many folks on eBay sell the older versions of the Windows (XP/Vista) desktop software, Parallels but if you have upgraded to the latest MAC OS, Snow Leopard, it won't work and after installing you get a message "this version of Parallels is not compatible". To upgrade costs another £30 via the Parallels website. Looks like you have to buy the latest version 4.0, or VMWare Fusion (which offers free upgrade to the latest version).
Have something to share, create your own guide... Write a guide
Explore more guides