US PSP games may no longer work on a UK PSP

Views 1 Like Comments Comment
Like if this guide is helpful
I recently saw a posting on gamefaqs.com relating to Sony's 3.11 firmware and later and the introduction by Sony of some coding that will prevent some but not all US games working on a UK PSP.
In the posting I read, the later updates of Sony's firmware i.e 3.11 and above prevented you from playing the US version of SOCOM 2.
I tested the theory since I'd updated my firmware to 3.11 and the posting was correct, the game doesn't work. You need to downgrade back to 3.10.
I thought I might point out this little detail since in the future it looks like we could end up buying a US game that won't work.
I suggest therefore that before buying check with the seller to ensure the game will work with the firmware you are running.
Have something to share, create your own guide... Write a guide
Explore more guides